ACM题目HangOver题意是什么

问题描述:

ACM题目HangOver题意是什么
How far can you make a stack of cards overhang a table?If you have one card,you can create a maximum overhang of half a card length.(We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length,and the bottom one overhang the table by a third of a card length,for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths.In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ...+ 1/(n + 1) card lengths,where the top card overhangs the second by 1/2,the second overhangs tha third by 1/3,the third overhangs the fourth by 1/4,etc.,and the bottom card overhangs the table by 1/(n + 1).This is illustrated in the figure below.
The input consists of one or more test cases,followed by a line containing the number 0.00 that signals the end of the input.Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
For each test case,output the minimum number of cards necessary to achieve an overhang of at least c card lengths.Use the exact output format shown in the examples.
Sample Input:
1.00
3.71
0.04
5.19
0.00
Sample Output:
3 card(s)
61 card(s)
1 card(s)
273 card(s)
1个回答 分类:英语 2014-11-04

问题解答:

我来补答
# include
main()
{
int i;
float len,s;
while(1)
{
scanf("%f",&len);
s = 0.0;
if(0==len) break;
for(i = 2; ; i++)
{
s+=1.0/i;
if(s >= len)
break;
}
printf("%d card(s)\n",i-1);
}
return 0;
}
 
 
展开全文阅读
剩余:2000
上一页:指函数和对函数
下一页:字丑请见谅。